BPV not venting properly - 2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-22-2014, 07:59 PM Thread Starter
broseph09
Junior Member
Points: 690, Level: 13
Points: 690, Level: 13 Points: 690, Level: 13 Points: 690, Level: 13
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
BPV not venting properly

About 2 months ago I put in the Cobb XLE bpv and it was working great, it would vent pretty loud when running it 50/50. About 2 weeks after that I upgraded my fuel pump internals (autotech) and after getting everyhing back together my BPV makes barely any noise when venting now. Between me and a couple other friends we have gone completely through everything that we know could cause it. Checked all the piping for cracks and being loose and found one cracked vacuum line but replacing that hasn't changed anything. Everything else seems to work ok and there's no other different noises in the turbo spooling or anything. Any help on this would be greatly appreciated, thanks.
broseph09 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-28-2015, 10:30 PM
222speed3
Senior Member
Points: 1,274, Level: 19
Points: 1,274, Level: 19 Points: 1,274, Level: 19 Points: 1,274, Level: 19
Activity: 60%
Activity: 60% Activity: 60% Activity: 60%
 
222speed3's Avatar
 
Join Date: Nov 2015
Posts: 171
Thanks: 3
Thanked 10 Times in 10 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
Speeds are set up originally to fully recirculate. It is good to stay full recirculating unless your setup and tuned for it.

COBB Tuning - MAZDASPEED XLE Bypass Valve

Good info on the FAQs here

Now 2014 Mazda 3 S-GT AT


Old 8.5 Speed GT From 2010-2015
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
222speed3 is offline  
post #3 of 3 (permalink) Old 12-20-2015, 04:38 PM
222speed3
Senior Member
Points: 1,274, Level: 19
Points: 1,274, Level: 19 Points: 1,274, Level: 19 Points: 1,274, Level: 19
Activity: 60%
Activity: 60% Activity: 60% Activity: 60%
 
222speed3's Avatar
 
Join Date: Nov 2015
Posts: 171
Thanks: 3
Thanked 10 Times in 10 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
I am a dope. Realized I responded to some old shyyyte. Bring it back lol. To also correct myself. Best to go back over the previous install and check all connections. Make sure the BPV is set up to recirculate. Would do anyway as a troubleshooting technique to see what happens.

Now 2014 Mazda 3 S-GT AT


Old 8.5 Speed GT From 2010-2015
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
222speed3 is offline  
Sponsored Links
Advertisement
 
Reply

Tags
bpv , properly , venting

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome