Long Startup - 2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums
User Tag List

 1Likes
  • 1 Post By Fluffy6079
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-15-2016, 09:54 AM Thread Starter
Fluffy6079
Junior Member
Points: 1,176, Level: 18
Points: 1,176, Level: 18 Points: 1,176, Level: 18 Points: 1,176, Level: 18
Activity: 6%
Activity: 6% Activity: 6% Activity: 6%
 
Fluffy6079's Avatar
 
Join Date: Jul 2015
Location: Riverside, AL
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
Garage
Long Startup

For the past few weeks I've had long startup times in my 2010 Mazdaspeed 3. I'll get in and push the button and it takes a lot longer to crank the engine that it should. It only seems to do it once the car has been sitting for several hours. If I drive, park somewhere for a while, then start it up to leave it fires right up. The obvious thing to me would be the fuel pressure regulator, but I've had a hard time finding any posts (here and elsewhere) where people have definitively resolved the issue and I don't want to go through all the trouble to pull the gas tank for nothing. Has anyone else experienced this problem and been able to fix it?

"I do what I can. Sometimes, I do what I can't."
Fluffy6079 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-20-2016, 12:59 PM Thread Starter
Fluffy6079
Junior Member
Points: 1,176, Level: 18
Points: 1,176, Level: 18 Points: 1,176, Level: 18 Points: 1,176, Level: 18
Activity: 6%
Activity: 6% Activity: 6% Activity: 6%
 
Fluffy6079's Avatar
 
Join Date: Jul 2015
Location: Riverside, AL
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
Garage
Anyone? Has no one been able to figure out a fix for this?

"I do what I can. Sometimes, I do what I can't."
Fluffy6079 is offline  
post #3 of 5 (permalink) Old 07-04-2016, 11:19 AM Thread Starter
Fluffy6079
Junior Member
Points: 1,176, Level: 18
Points: 1,176, Level: 18 Points: 1,176, Level: 18 Points: 1,176, Level: 18
Activity: 6%
Activity: 6% Activity: 6% Activity: 6%
 
Fluffy6079's Avatar
 
Join Date: Jul 2015
Location: Riverside, AL
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
Garage
I have been able to fix the issue. My car eventually started running a bit rough at idle in addition to the cranking issue. I took my EGR valve off and found the spring to be stuck. I used carburetor cleaner and thoroughly cleaned it, reinstalled it, and all my problems were solved.
btijet likes this.
Fluffy6079 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 09-12-2016, 12:16 PM
Fizboy
Junior Member
Points: 1,826, Level: 25
Points: 1,826, Level: 25 Points: 1,826, Level: 25 Points: 1,826, Level: 25
Activity: 7%
Activity: 7% Activity: 7% Activity: 7%
 
Join Date: Apr 2014
Location: Blacksburg, VA
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
Same Issue

I have been having the same issue. I will try cleaning the EGR valve and see if I get the same result and report back.
Fizboy is offline  
post #5 of 5 (permalink) Old 11-26-2016, 09:06 AM Thread Starter
Fluffy6079
Junior Member
Points: 1,176, Level: 18
Points: 1,176, Level: 18 Points: 1,176, Level: 18 Points: 1,176, Level: 18
Activity: 6%
Activity: 6% Activity: 6% Activity: 6%
 
Fluffy6079's Avatar
 
Join Date: Jul 2015
Location: Riverside, AL
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
Garage
Quote:
Originally Posted by Fizboy View Post
I have been having the same issue. I will try cleaning the EGR valve and see if I get the same result and report back.
I'm curious to see if you were able to fix your issue as well. It's been a few months now and I still haven't had any more problems.

"I do what I can. Sometimes, I do what I can't."
Fluffy6079 is offline  
Sponsored Links
Advertisement
 
Reply

Tags
long , startup

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome