RMM Clunk - 2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 06-07-2016, 06:06 PM Thread Starter
Surge101
Junior Member
Points: 2,521, Level: 30
Points: 2,521, Level: 30 Points: 2,521, Level: 30 Points: 2,521, Level: 30
Activity: 36%
Activity: 36% Activity: 36% Activity: 36%
 
Join Date: May 2013
Posts: 26
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
RMM Clunk

I just changed to a Damond Motorsports RMM, I know to expect more vibes with this mount over the stock RMM. The vibes really aren't that bad, however one thing i'm noticing is a clunk. At start up theres a fairly loud clunk and pretty much when i'm shifting/let off throttle there is a clunk. Is this normal?
Surge101 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-07-2016, 11:19 PM
pdc001
Senior Member
Points: 66,608, Level: 100
Points: 66,608, Level: 100 Points: 66,608, Level: 100 Points: 66,608, Level: 100
Activity: 10%
Activity: 10% Activity: 10% Activity: 10%
 
pdc001's Avatar
 
Join Date: Jan 2012
Posts: 1,793
Thanks: 981
Thanked 709 Times in 499 Posts
Mentioned: 108 Post(s)
Tagged: 1 Thread(s)
                   
What did you torque the bolts to ?
pdc001 is offline  
post #3 of 7 (permalink) Old 06-08-2016, 11:04 AM Thread Starter
Surge101
Junior Member
Points: 2,521, Level: 30
Points: 2,521, Level: 30 Points: 2,521, Level: 30 Points: 2,521, Level: 30
Activity: 36%
Activity: 36% Activity: 36% Activity: 36%
 
Join Date: May 2013
Posts: 26
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
I had it done at a local performance shop. I guess i'll go ahead and check that everything is torqued to spec when I get a chance. Is there risk of something being damaged with that clunk until I get the chance to check everything out in a day or so?
Surge101 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 06-08-2016, 12:10 PM
pdc001
Senior Member
Points: 66,608, Level: 100
Points: 66,608, Level: 100 Points: 66,608, Level: 100 Points: 66,608, Level: 100
Activity: 10%
Activity: 10% Activity: 10% Activity: 10%
 
pdc001's Avatar
 
Join Date: Jan 2012
Posts: 1,793
Thanks: 981
Thanked 709 Times in 499 Posts
Mentioned: 108 Post(s)
Tagged: 1 Thread(s)
                   
I just wouldn't be boosting a lot since it's a torque mount. Is that the only thing that was changed or did you have any other work done?
pdc001 is offline  
post #5 of 7 (permalink) Old 06-08-2016, 08:05 PM Thread Starter
Surge101
Junior Member
Points: 2,521, Level: 30
Points: 2,521, Level: 30 Points: 2,521, Level: 30 Points: 2,521, Level: 30
Activity: 36%
Activity: 36% Activity: 36% Activity: 36%
 
Join Date: May 2013
Posts: 26
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
Quote:
Originally Posted by pdc001 View Post
I just wouldn't be boosting a lot since it's a torque mount. Is that the only thing that was changed or did you have any other work done?
Just the HPFP internals.
Surge101 is offline  
post #6 of 7 (permalink) Old 06-09-2016, 03:08 PM Thread Starter
Surge101
Junior Member
Points: 2,521, Level: 30
Points: 2,521, Level: 30 Points: 2,521, Level: 30 Points: 2,521, Level: 30
Activity: 36%
Activity: 36% Activity: 36% Activity: 36%
 
Join Date: May 2013
Posts: 26
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
Checked it out, not sure if this could be the issue, but the install guide specifies for two large washers on the bolt head side and one small washer on the nut side, what I saw was two washers on the nut side and one on the bolt head side. Wondering if that could be significant enough to be the issue.
Surge101 is offline  
post #7 of 7 (permalink) Old 06-09-2016, 07:54 PM
sin_loki
Admiral Obvious
Points: 10,024, Level: 66
Points: 10,024, Level: 66 Points: 10,024, Level: 66 Points: 10,024, Level: 66
Activity: 20%
Activity: 20% Activity: 20% Activity: 20%
 
sin_loki's Avatar
 
Join Date: Feb 2013
Location: Lompoc, CA
Posts: 1,799
Thanks: 363
Thanked 567 Times in 402 Posts
Mentioned: 111 Post(s)
Tagged: 1 Thread(s)
                 
Garage
if in doubt, RTFM

Welcome to the internet. A wonderful place where no race, gender, political view, or mental state will leave unharmed.
sin_loki is offline  
Sponsored Links
Advertisement
 
Reply

Tags
clunk , rmm

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome