auto trans sometimes won't shift up from third - 2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-05-2017, 02:44 PM Thread Starter
redzeker
Junior Member
Points: 2,435, Level: 29
Points: 2,435, Level: 29 Points: 2,435, Level: 29 Points: 2,435, Level: 29
Activity: 7%
Activity: 7% Activity: 7% Activity: 7%
 
Join Date: Feb 2014
Posts: 27
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
auto trans sometimes won't shift up from third

2010 Mazda3 S hatchback with automatic transmission and about 90k miles. The issue is intermittent, but seems to happen most often within the first 15 minutes of driving the car.

It simply won't shift up from 3rd without me putting it into manual mode and doing it myself, after which it seems to have no trouble. When it does work, it seems to be shifting at higher RPMs than it used to, but that could just me being paranoid and making it up. No warning lights in the cluster.

Thoughts? Shifter solenoid or something like that? Speed sensor?

2010 3s A/T Hatch Crystal Pearl White
Mods: K&N drop-in air filter
redzeker is offline  
Sponsored Links
Advertisement
 
Reply

Tags
auto , shift , trans

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome