Cruise Control won't engage - 2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 22 (permalink) Old 03-31-2013, 10:49 AM Thread Starter
isteal
Junior Member
Points: 191, Level: 3
Points: 191, Level: 3 Points: 191, Level: 3 Points: 191, Level: 3
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
Exclamation Cruise Control won't engage

I have a new 2012 3i GT sedan with 500 miles on it. I have issues twice in the last week where the cruise control would not engage. Both times have been on the interstate and since I live in indiana, it's flat interstate. The cruise main light will come on yellow, but when I try and set the speed it won't engage. The cruise light won't turn green. I tried to turn it off with the buttons on the left side of the wheel and turn it back on with no luck. I know how to operate it, but it won't engage. If I come to a stop, turn off the car, then start back up and go, it has started working. I haven't noticed any issues with it losing speed, it just works or it doesn't. Any thoughts? I know I can take it in for service, but it frustrating on a brand new car. My wife and a friend also bought new 3s the same day and they haven't had any issues with theirs...
isteal is offline  
Sponsored Links
Advertisement
 
post #2 of 22 (permalink) Old 03-31-2013, 11:55 AM
Mikes85
Senior Member
Points: 2,269, Level: 28
Points: 2,269, Level: 28 Points: 2,269, Level: 28 Points: 2,269, Level: 28
Activity: 20%
Activity: 20% Activity: 20% Activity: 20%
 
Mikes85's Avatar
 
Join Date: Dec 2012
Location: Reading, PA
Posts: 317
Thanks: 7
Thanked 36 Times in 29 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
 
Brake light switch sticking maybe? Have it checked by the dealer, with 500 miles on it there should be NOTHING wrong.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mikes85 is offline  
post #3 of 22 (permalink) Old 03-31-2013, 12:19 PM
derekivey
Senior Member
Points: 8,997, Level: 63
Points: 8,997, Level: 63 Points: 8,997, Level: 63 Points: 8,997, Level: 63
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
derekivey's Avatar
 
Join Date: Dec 2010
Location: San Jose, CA
Posts: 1,131
Thanks: 52
Thanked 79 Times in 57 Posts
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
   
Quote:
Originally Posted by isteal View Post
I have a new 2012 3i GT sedan with 500 miles on it. I have issues twice in the last week where the cruise control would not engage. Both times have been on the interstate and since I live in indiana, it's flat interstate. The cruise main light will come on yellow, but when I try and set the speed it won't engage. The cruise light won't turn green. I tried to turn it off with the buttons on the left side of the wheel and turn it back on with no luck. I know how to operate it, but it won't engage. If I come to a stop, turn off the car, then start back up and go, it has started working. I haven't noticed any issues with it losing speed, it just works or it doesn't. Any thoughts? I know I can take it in for service, but it frustrating on a brand new car. My wife and a friend also bought new 3s the same day and they haven't had any issues with theirs...
I had this issue once. I never figured out what caused it. It started working again after I turned the car off and back on. No problems since...

2012 Mazda 3 i GT Hatch w/ tech package - Sky Blue
Mods: WeatherTech Floor Mats | OEM Fog Lights | TRS Morimoto Elite 3Five 4300K Fogs | OEM Zoom Zoom License Plate Frame | OEM Sunshade | 35% Front / 20% Rear Tint | CorkSport LED Kit | OEM LED Tail Lights | Turn Signal Side Mirrors

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by derekivey; 03-31-2013 at 12:22 PM.
derekivey is offline  
Sponsored Links
Advertisement
 
post #4 of 22 (permalink) Old 03-31-2013, 01:31 PM
Rherold9
On that college budget
Points: 40,648, Level: 100
Points: 40,648, Level: 100 Points: 40,648, Level: 100 Points: 40,648, Level: 100
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Rherold9's Avatar
 
Join Date: Aug 2011
Location: Richmond, VA
Posts: 5,273
Thanks: 687
Thanked 723 Times in 609 Posts
Mentioned: 87 Post(s)
Tagged: 0 Thread(s)
                   
Take to dealer? Either brake switch is not working properly or ECU needs a re-flash.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Rherold9 is offline  
post #5 of 22 (permalink) Old 04-01-2013, 03:44 AM
john doe
Senior Member
Points: 2,662, Level: 31
Points: 2,662, Level: 31 Points: 2,662, Level: 31 Points: 2,662, Level: 31
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2012
Posts: 182
Thanks: 0
Thanked 18 Times in 15 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
 
Strait to the dealer. My cruise has been flawless. It has worked in every gear and all the way down to 35mpg or up to 83mph
john doe is offline  
post #6 of 22 (permalink) Old 04-01-2013, 05:15 AM
90210
Senior Member
Points: 4,742, Level: 43
Points: 4,742, Level: 43 Points: 4,742, Level: 43 Points: 4,742, Level: 43
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
90210's Avatar
 
Join Date: Feb 2013
Location: West Los Angeles, CA
Posts: 1,579
Thanks: 10
Thanked 190 Times in 164 Posts
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
       
Trade it for a ms3 like the one your friend bought
90210 is offline  
post #7 of 22 (permalink) Old 04-01-2013, 12:35 PM
missPrius
Junior Member
Points: 64, Level: 1
Points: 64, Level: 1 Points: 64, Level: 1 Points: 64, Level: 1
Activity: 2%
Activity: 2% Activity: 2% Activity: 2%
 
Join Date: Mar 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
Cruise Control won't engage

I have the exact same cruise problem isteal described; I bought a 2013 Mazda 3 i GT hatchback in March. That cruise problem happened twice in March. I hate these intermittent problems that I can't demonstrate to the dealer. I was at the dealer this morning for it and they didn't find anything about it in their Mazda problem database.

@isteal: Just for reference what type of cruise controls are on your steering wheel? Mine has what the manual calls 'Type B' controls: Cruise On/Off buttons on the left half of the steering and SET+/-, Cancel, Resume on the right side.
missPrius is offline  
post #8 of 22 (permalink) Old 04-02-2013, 12:01 AM Thread Starter
isteal
Junior Member
Points: 191, Level: 3
Points: 191, Level: 3 Points: 191, Level: 3 Points: 191, Level: 3
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
Mine has the same style of controls. On / off on the left and set controls on the right... "Type B"
isteal is offline  
post #9 of 22 (permalink) Old 04-02-2013, 12:02 AM Thread Starter
isteal
Junior Member
Points: 191, Level: 3
Points: 191, Level: 3 Points: 191, Level: 3 Points: 191, Level: 3
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
Quote:
Originally Posted by 90210 View Post
Trade it for a ms3 like the one your friend bought
Maybe next time around! I think it's best to learn to drive a manual before making the plunge! Lol
isteal is offline  
post #10 of 22 (permalink) Old 04-12-2013, 08:55 PM
TimPro
Member
Points: 2,007, Level: 27
Points: 2,007, Level: 27 Points: 2,007, Level: 27 Points: 2,007, Level: 27
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Feb 2013
Posts: 55
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
 
Just had this problem today. Described perfectly by OP. I turned the car off at a light and back on and it worked fine. Strange. And I was literally at the dealership today for a oil change/ tire rotation.


Sent from AutoGuide.com App
TimPro is offline  
Sponsored Links
Advertisement
 
Reply

Tags
control , cruise , engage

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome