Power steering feels light and disconnected now? - 2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 10-09-2016, 03:06 AM Thread Starter
Jack4952
Junior Member
Points: 2,034, Level: 27
Points: 2,034, Level: 27 Points: 2,034, Level: 27 Points: 2,034, Level: 27
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2014
Location: Atlanta, GA
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
 
Power steering feels light and disconnected now?

I bought my 2011 2.5 hatchback used a few years ago. One of the driving characteristics that liked when I bought it was that the steering felt somewhat heavy and gave great feedback.

Well, fast forward a year and I had a minor accident. One of the first things I noticed when I got my car back from the shop was that the steering felt noticeably lighter than before the accident. Now the steering has sort of a disconnected feeling and seems over-boosted and darty when I hit certain sections of high speed turns and elevation changes on the interstate. It's not a very comforting feeling and I usually slow down whereas I didn't have to do that before.

Do you guys have any idea what could be going on? Could it be an alignment issue or maybe something else?
Jack4952 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-07-2016, 07:50 AM
mekanick
Senior Member
Points: 8,616, Level: 62
Points: 8,616, Level: 62 Points: 8,616, Level: 62 Points: 8,616, Level: 62
Activity: 15%
Activity: 15% Activity: 15% Activity: 15%
 
mekanick's Avatar
 
Join Date: Dec 2012
Posts: 1,190
Thanks: 246
Thanked 233 Times in 201 Posts
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
         
Thats definitely an alignment issue. Id get that looked at maybe something is bent or its just way out of alignment
mekanick is offline  
post #3 of 5 (permalink) Old 11-08-2016, 09:58 AM
kms1990
Demon Spawn
Points: 4,921, Level: 44
Points: 4,921, Level: 44 Points: 4,921, Level: 44 Points: 4,921, Level: 44
Activity: 37%
Activity: 37% Activity: 37% Activity: 37%
 
kms1990's Avatar
 
Join Date: Jul 2015
Location: fort worth,tx
Posts: 627
Thanks: 10
Thanked 34 Times in 34 Posts
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
 
Garage
Quote:
Originally Posted by mekanick View Post
Thats definitely an alignment issue. Id get that looked at maybe something is bent or its just way out of alignment
agreed, or perhaps the body shop did not redo your power steering right? what part of the car got hit? front right? if it was the front right that's where the electric power steering pump lives (under the headlight the fluid reservoir sits right on top of it) maybe that is damaged, or the steering rack, air in the system usually makes steering hard but can make it vague in rare instances, maybe bleed your power steering system, either way I would bring it back to that body shop, a good shop will look over their work if there is an issue


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"Give into the Night"
kms1990 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 11-08-2016, 10:49 AM
arathol
Senior Member
Points: 3,389, Level: 36
Points: 3,389, Level: 36 Points: 3,389, Level: 36 Points: 3,389, Level: 36
Activity: 99%
Activity: 99% Activity: 99% Activity: 99%
 
arathol's Avatar
 
Join Date: Jun 2016
Location: central ct
Posts: 1,051
Thanks: 0
Thanked 131 Times in 113 Posts
Mentioned: 50 Post(s)
Tagged: 0 Thread(s)
     
Almost certainly an alignment issue. Sounds like the front toe adjustments are way off.
arathol is offline  
post #5 of 5 (permalink) Old 11-08-2016, 04:44 PM
kms1990
Demon Spawn
Points: 4,921, Level: 44
Points: 4,921, Level: 44 Points: 4,921, Level: 44 Points: 4,921, Level: 44
Activity: 37%
Activity: 37% Activity: 37% Activity: 37%
 
kms1990's Avatar
 
Join Date: Jul 2015
Location: fort worth,tx
Posts: 627
Thanks: 10
Thanked 34 Times in 34 Posts
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
 
Garage
Quote:
Originally Posted by arathol View Post
Almost certainly an alignment issue. Sounds like the front toe adjustments are way off.
agreed and as stated above take it back to the shop that did the work, good shops stand behind the work they do, and if something is wrong they make it right. many places offer free alignment checks, maybe stop in one of these places before going back to confirm the alignment is off or not. honestly wrecks suck though and the car will never be the same. just ask the many I have totaled. I had a seizure and ran over a curb in my old protégé 5 and it never drove right again after that, it was not bad and other people never noticed but I did and so did my dad (who had previously owned the car before me) there is always just something missing from a car after the accident no matter how minor. especially front end ones. sometimes they wont hold alignments ever again, sometimes something is bent and no one ever sees it. but as the other 2 have stated above, and I agree its probably an alignment issue. or at least that's where you need to start and make sure the body shop that did the work takes care of you.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"Give into the Night"
kms1990 is offline  
Sponsored Links
Advertisement
 
Reply

Tags
disconnected , feels , light , power , steering

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome