Power steering pump - 2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 11-26-2016, 08:19 PM Thread Starter
Jorgepereira
Junior Member
Points: 14, Level: 1
Points: 14, Level: 1 Points: 14, Level: 1 Points: 14, Level: 1
Activity: 5%
Activity: 5% Activity: 5% Activity: 5%
 
Join Date: Nov 2016
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
Power steering pump

I have a mazda 3 2010 hatchback and i changed my power steering pump and the new one makes a whining noise but my old one didnt and i want to know how to fix it please help:weary:
Jorgepereira is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 11-28-2016, 12:03 PM
kms1990
Demon Spawn
Points: 4,921, Level: 44
Points: 4,921, Level: 44 Points: 4,921, Level: 44 Points: 4,921, Level: 44
Activity: 37%
Activity: 37% Activity: 37% Activity: 37%
 
kms1990's Avatar
 
Join Date: Jul 2015
Location: fort worth,tx
Posts: 627
Thanks: 10
Thanked 34 Times in 34 Posts
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
 
Garage
is the fluid full, the correct type and did you bleed the system after you did the job?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"Give into the Night"
kms1990 is offline  
post #3 of 6 (permalink) Old 11-28-2016, 04:56 PM
WheelMcCoy
Senior Member
Points: 4,068, Level: 40
Points: 4,068, Level: 40 Points: 4,068, Level: 40 Points: 4,068, Level: 40
Activity: 5%
Activity: 5% Activity: 5% Activity: 5%
 
WheelMcCoy's Avatar
 
Join Date: Jun 2012
Posts: 133
Thanks: 45
Thanked 18 Times in 18 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
 
2010 Mazda3 sedan here. The power steering on it is electric hydraulic assist; even when new, there was a whine when I turned the wheel while idling in the garage. On the road, however, there is no whine. I think the whine is normal, and it is happening less and less as I put on the miles.

Here's some interesting reading from Edmunds, although it doesn't directly address your concerns:
An Additional Note About The Steering Type - 2012 Mazda 3 Long-Term Road Test
WheelMcCoy is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 11-29-2016, 09:33 AM
kms1990
Demon Spawn
Points: 4,921, Level: 44
Points: 4,921, Level: 44 Points: 4,921, Level: 44 Points: 4,921, Level: 44
Activity: 37%
Activity: 37% Activity: 37% Activity: 37%
 
kms1990's Avatar
 
Join Date: Jul 2015
Location: fort worth,tx
Posts: 627
Thanks: 10
Thanked 34 Times in 34 Posts
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
 
Garage
I notice a small "buzz" like electrical current in a high voltage wire sound not really a whine when I use my power steering in the driveway or at low speeds and I know this is the electric pump just doing its thing, my 08 made the same exact noise, at the same times, neither the 11 or 08 have or gave me any issues with power steering, except when I shut my 08 off while coasting on an empty access road to a freeway once, the power steering did not "boot" back up when I started back the car and it stayed off until I made a decently hard turn into a parking lot on the same drive, then it just came back on and never had anything else go wrong.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"Give into the Night"
kms1990 is offline  
post #5 of 6 (permalink) Old 01-18-2017, 07:49 PM
Theonlyforte
Member
Points: 2,252, Level: 28
Points: 2,252, Level: 28 Points: 2,252, Level: 28 Points: 2,252, Level: 28
Activity: 18%
Activity: 18% Activity: 18% Activity: 18%
 
Join Date: Feb 2015
Location: California
Posts: 41
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
 
Garage
My car whines too and I've heard other Mazda 3s whine so I think it's all the cars.
Theonlyforte is offline  
post #6 of 6 (permalink) Old 01-19-2017, 05:54 PM
kms1990
Demon Spawn
Points: 4,921, Level: 44
Points: 4,921, Level: 44 Points: 4,921, Level: 44 Points: 4,921, Level: 44
Activity: 37%
Activity: 37% Activity: 37% Activity: 37%
 
kms1990's Avatar
 
Join Date: Jul 2015
Location: fort worth,tx
Posts: 627
Thanks: 10
Thanked 34 Times in 34 Posts
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
 
Garage
its just the pump doing its thing guys, when you turn hard especially at stopped or low speed it needs a lot of fluid pressure to make the assist happen right, well that puts demand on the pump more than just turning at 30mph or so as the car when moving does not need as much force to turn. the more the pump has to build pressure the more it will work, the more it works the more electrical demand and then you get a noise, mine does it in parking lots a lot, its fine. its the same idea as the regular belt driven pumps, when you turn hard while stopped or at low speed they have to build a lot of pressure, well that makes them whine. same with an electric pump.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"Give into the Night"
kms1990 is offline  
Sponsored Links
Advertisement
 
Reply

Tags
power , pump , steering

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome